
 

1 
 

ClearClick® Vintage 

Suitcase Turntable (VT32) 
Quick Start Guide & User’s Manual 

 

 

         Full 5-Year Warranty + 

         FREE USA-Based Tech Support 

If you have any issue or question regarding this product, 

contacting us directly is the fastest way to resolve the 

issue. We are ClearClick®, a small USA-based business, 

and we stand behind our products with a full 5-year warranty 

& free USA tech support. If you have any issues with our 

product, please contact us at support@clearclick.tech. 

 

www.ClearClick.tech 

 

mailto:support@clearclick.tech
http://www.clearclick.tech/
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Register Your Product & Browse Our Products 

Thank you for your purchase! Make sure you register your 

product & check out our other unique & easy-to-use 

technology at: 

www.ClearClick.tech 

 

Safety Precautions 

1) Do not disassemble the unit. 

2) Do not operate the unit around water or rain. 

3) Do not operate the unit around any kind of machines 

or appliances (other than computers). 

4) Turn off and unplug the unit when not in use. 

5) Do not allow young children to use this device.  

 

Thank You! 

Thank you for your purchase of the ClearClick® Vintage 

Suitcase Turntable! We appreciate your business. 

 

At ClearClick®, we try to make our technology as clear to 

understand and use as possible. But if you get stuck at any 

point, you qualify for FREE USA-based tech support as a 

ClearClick® customer. Just email us at: 

support@clearclick.tech. 

 

(Make sure you explain your issue in detail and tell us that 

you’re using our ClearClick® Vintage Suitcase Turntable, 

model VT32). Our USA-based tech support team members 

http://www.clearclick.tech/
mailto:support@clearclick.tech
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will normally reply to you within 24-48 business hours -- 

usually less.) 

 

To get started with your ClearClick® Vintage Suitcase 

Turntable, please see the quick start guide on the following 

pages. 

 

What’s In The Box 

 ClearClick® Vintage Suitcase Turntable 

(Model Number VT32) 

 Power Adapter 

 USB Cable 

 Software CD 

 User’s Manual 

 

NOTE: If you believe you are missing any parts, or if you 

received a part that is broken, please contact us directly at 

parts@clearclick.tech. For all other technical issues or 

support, please contact us at support@clearclick.tech.  

 

 

 

 

 

mailto:parts@clearclick.tech
mailto:support@clearclick.tech
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MORE PRODUCTS YOU MIGHT LIKE FROM 

Cassette2USB Converter 

(Convert Audio Tapes To Digital) 

 

 

 

QuickConvert Photo, Slide, & 

Negative Scanner 

 

 

 

Video2Digital Converter (Convert 

Video Tapes To Digital) 

 

 

 

Film2USB Converter (Slide & Negative 

Scanner) 

 

 

 

Retro Wooden Radio with Bluetooth 

 

LEARN MORE & BUY NOW AT 

WWW.CLEARCLICK.TECH 

WWW.CLEARCLICK.TECH
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QUICK START – Listening To Records 

1. Plug the power adapter into the back of the turntable. 

Plug the other end into any electrical outlet. 

2. Switch the knob on the top of the turntable to “PHONO.” 

Turn on the power switch. The power LED will light up 

red. 

3. Remove the white plastic protective cover on the 

turntable needle. Remove the black protective twist ties 

on the turntable “arm”. 

 

4. Place a record on the turntable and select the desired 

speed (33/45/78) according to the record. 

NOTE: If you are playing a 45 RPM record, use the 

included 45 RPM adapter located in the holder near the 

tone arm. 

 

5. Open the tone arm clip to release the tone arm. Place the 

tone arm onto the record. The turntable will begin to spin 

after the arm is moved toward the record. 

 

6. Turn the VOLUME CONTROL KNOB to adjust the 

volume. 

 

7. If the Auto Stop Control Switch is turned ON, the record 

will stop automatically when finished. If Auto Stop Control 

Switch is turned OFF, the record will NOT stop 

automatically when finished. 
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NOTE: The AUTO STOP function works with most 33 RPM 

vinyl records. However, it may not work with all records.  

 

QUICK START – Playing Music via Bluetooth 

1. Plug the power adapter into the back of the turntable. 

Plug the other end into any electrical outlet. 

2. Switch the knob on the top of the turntable to “BT.” 

Turn on the power switch. The power LED will light up 

blue. 

3. On your phone, tablet, or other Bluetooth device, scan for 

Bluetooth devices and connect to the one named 

“Vintage Turntable.” 

 

4. The power LED will become solid blue once the turntable 

is connected to your Bluetooth device. 

 

5. Start playing music on your Bluetooth device. Turn the 

VOLUME CONTROL KNOB to adjust the volume. (NOTE: 

You may need to adjust the volume on your phone or 

Bluetooth device as well.) 

 

 

QUICK START – Playing Music via AUX IN 

1. Plug the power adapter into the back of the turntable. 

Plug the other end into any electrical outlet. 
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2. Switch the knob on the top of the turntable to “LINE IN.” 

3. Connect your phone or MP3 player to the AUX IN port 

using an “aux in” (3.5mm to 3.5mm) audio cable (not 

included). 

 

4. Start playing music on your iPod or MP3 player, and 

adjust the volume both on the device and on the turntable. 

 

QUICK START – Converting Records To 

MP3’s Using Your PC or Mac 

1. On your PC or Mac, load and install the included 

software CD – OR you can download the software from: 

 

PC: http://www.ClearClickSoftware.com/PC-Setup.exe  

MAC: http://www.ClearClickSoftware.com/MAC-Setup.dmg  

(After the file has downloaded it, double-click the setup 

file to install the software.) 

 

If you are using a PC, the setup wizard will appear. Click 

“Next” in the prompts until the software is fully installed. 

 

If you are using a Mac, drag the “Audacity” software icon 

into your Applications folder to install the software. 

2. After the software is installed, plug the turntable into your 

PC or Mac using the included USB cable. 

http://www.clearclicksoftware.com/PC-Setup.exe
http://www.clearclicksoftware.com/MAC-Setup.dmg
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3. Open the “Audacity” software that you just installed on 

your PC or Mac. NOTE: the turntable must already be 

plugged in BEFORE opening the software. 

 

4. In the software, click “Edit -> Preferences” (or Audacity -> 

Preferences on Mac). 

 

5. Under the “Devices” section, set the “Recording Device” 

to the correct settings, as shown below. It will read 

something like: “AudioDevice on USB Bus” or “USB 

Audio Device/USB Microphone”).” Also, set Channels to 

“2 (Stereo).” 

 

 

6. Load a record onto the turntable and start playing it (as 

described in the first Quick Start Guide) 

 

7. Click the “Record” icon in the software, and your record 

will start transferring to your computer! 

 

8. When the record has finished playing, click the “Stop” 

icon in the software. 

 

9. To save your recorded audio, click File -> Export Audio 

(Audacity -> Export Audio on Mac). 
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10. Choose the name, location, and file type that you’d like 

to save your audio file as, and click “Save.” We 

recommend saving in “MP3” format. 

 

11. The first time that you save an MP3 recording, the 

software may prompt you for a file called “lame_enc.dll.” 

This file can be downloaded at: 

http://www.clearclicksoftware.com/MP3-encoder.zip 

(Download the ZIP file and extract the DLL file. When 

Audacity asks for the “lame_enc.dll” file, point it to this 

file.) 

 

12. Your audio will be saved as a digital MP3 file! 
 

How To Remove Noise From Your Recordings 

1. Using the software included 

(see above quick start guide), 

drag the cursor over a portion of 

the audio track to select a part 

which contains ONLY 

silence/noise (no music), as 

shown here. 

 

 

 

 

 

 

http://www.clearclicksoftware.com/MP3-encoder.zip
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2. Click the Effect menu  Noise Reduction. 
 

 
 

3. Click “Get Noise Profile” button. The Noise Removal 

window will now close automatically. 

 

4. Now, click and drag to select the part of the audio 

recording that you wish to remove noise from. If you wish to 

clean up the entire recording, use “Select All” under the “Edit 

Menu”.  

 

5. Repeat Step 2 to bring up the “Noise Removal” Window. 
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6. Adjust the level of noise removal by moving the slider in 

the “Noise Removal” window. To start with, we recommend 

using the minimum noise removal for optimum sound. Note: 

you can preview the audio before removing the noise by 

clicking on ‘Preview’. 

 

7. Click the ‘Remove Noise’ button. 

 

8. Remember to re-export your file if you want to save the 

changes. 
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Turntable Diagram 

 

 

1. RCA output – Use to connect to external speakers (not 

included) 

2. DC IN (power) jack 

3. 45 RPM adapter holder – Holds the included 45 RPM 

adapter. When not using the adapter, please place it in this 

holder. 

4. Lift lever 

5. USB jack – Use to connect to computer for converting 

the records to digital MP3 (see pg. 7) 
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6. 33 / 45/78 RPM switch – This switch controls the RPM of 

the turntable platter. 

7. AUX-IN port 

8. AUTO STOP ON/OFF switch 

9. Function switch knob (switches between turntable 

(phono), line in/aux in, and Bluetooth) 

10. Tone arm lock 

11. Power on/off and volume control knob  

12. Power indicator light 

13. Headphone jack 

14. Platter – Place your record here. Please use the 45 RPM 

adapter, if the spindle is the incorrect size. 

15. Ceramic cartridge/turntable needle 
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Frequently Asked Questions (FAQ) 

 

1. What computers is the USB turntable compatible with? 

 

The turntable is compatible with both Microsoft Windows 10, 

8, 7, Vista, XP and Apple Mac OS X. 

 

 

2. When I record audio from my converter, I don’t get 

any sound. 

 

Make sure you have the correct recording device set. Make 

sure the “microphone” recording level is set to about 2/3 of 

the way up. 

 

PC: Set the “Recording Device” to “USB Microphone/Audio 

Device” or “AudioDevice On USB Bus”. 

 

MAC: In the software, click Audacity  Preferences and set 

the “Recording Device” to “USB Microphone/USB Audio 

Device” (Device name may vary slightly) 

 

 

3. How do I save my audio recordings as MP3? 

 

After recording your audio recording, use the File/Audacity 

 Export Audio feature inside the software. 

 

The first time you do this, you will be asked to locate a file 
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called “lame_enc”  to add this feature to the software. This 

file can be downloaded at: 

 

http://www.clearclicksoftware.com/MP3-encoder.zip 

 

(Download the ZIP file and extract the DLL file. When 

Audacity asks for the “lame_enc.dll” file, point it to this file.) 

 

 

4. How do I use the turntable to import music into 

iTunes? 

 

First, convert your record to WAV or MP3 format and save it 

on your PC. You can then import your recordings into iTunes 

and put them on your iPod/iPad/iPhone. 

 

 

5. My audio recordings don’t sound good. 

 

1) Try setting the speed selector to the correct speed setting 

based on the type of record you are listening to. 

 

2) Turn down the “Recording” / “Microphone” volume in the 

software. 

 

3) Under File/Audacity  Preferences, set “Channels” to “2 

(Stereo)” in the “Devices” section. 

 

4) If your recordings still are low quality, it is possible that 

your original vinyl record's quality has degraded over time. 

http://www.clearclicksoftware.com/MP3-encoder.zip
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5) If you are running the noise removal feature, try recording 

without using the noise removal feature. Running this 

feature on recordings without enough noise to remove will 

result in poor recordings. 

 

 

6. The software doesn’t record audio correctly or I can’t 

hear anything during playback. 

 

1) After recording, unplug your turntable from your PC. Then 

export your recording as a WAV or MP3 file and exit the 

software. Finally, play your music in software such as 

Windows Media Player or iTunes. 

 

2) Make sure you have the correct recording device set. In 

the software, set the “Recording Device” to something like 

“USB Audio Device” or “USB Microphone.” 

 

 

7. How do I split up my recording into individual tracks? 

 

First, use the mouse to select a track. Do this by clicking and 

dragging between the silences (flat lines). Use the “Zoom 

In/Out” tool if necessary. 

 

Then, click File/Audacity  “Export Selected Audio.” Select 

a location to save the file. Repeat the process for the 

remaining tracks that are recorded. When finished, you may 

exit Audacity and say “no” when asked to save the file. 
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8. Is there a way to make the audio transfer faster? 

 

Transfers must be done at normal speed. This is because 

the turntable records the actual audio that is emitted by the 

player. 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

   

 

 

 

 

 

 

 

         Full 5-Year Warranty + 

         FREE USA-Based Tech Support 

If you have any issue or question regarding this product, 

contacting us directly is the fastest way to resolve the 

issue. We are ClearClick®, a small USA-based business, 

and we stand behind our products with a full 5-year warranty 

& free USA tech support. If you have any issues with our 

product, please contact us at support@clearclick.tech. 

 

www.ClearClick.tech 

 

mailto:support@clearclick.tech
http://www.clearclick.tech/
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